IL SEMBLE QUE VOUS UTILISEZ ADBLOC POUR BLOQUER LA PUBLICITÉ, AUCUNE PUB INTRUSIVE SUR FDZ ET PAS DE POPUP
FDZ EST GRATUIT DONC MERCI DE DÉSACTIVER VOTRE ADBLOCK ET DE BIEN VOULOIR PARTICIPER ET JOUER LE JEU


PAR SUITE D'ABUS LES SERVEURS CCCAM ET ABONNEMENT NE SONT PAS TOLÉRÉS SUR LE FORUM

Affichage des résultats 1 à 8 sur 8
Share |

Discussion: Xorg très lent à lancer !

  1. #1
    Date d'inscription
    mars 2009
    Localisation
    Entre la chaise et le clavier
    Messages
    461
    Remerciements
    0
    Remercié 0 fois dans 0 messages
    Pouvoir de réputation
    9

    GNU/Linux Xorg très lent à lancer !

    Salam,

    Je suis confronté depuis longtemps à un problème assez pénible sur mon archlinux : en effet, le boot depuis grub vers la console ne mets que 8 secondes, je m'authentifie, je lance un startx est là j'attends environ 15 secondes pour avoir le main.

    Je souligne que je n'utilise pas un un desktop environnement comme gnome ou kde mais un window manager lèger nommé Openbox.

    J'ai aussi le pilote propriétaires nvidia.

    Une solution pour rendre ça un peu plus rapide ?

    Cordialement.

  2. #2
    Date d'inscription
    janvier 2008
    Localisation
    Alger
    Messages
    1 251
    Remerciements
    0
    Remercié 1 fois dans 1 message
    Pouvoir de réputation
    11

    Par défaut Re : Xorg très lent à lancer !

    Je m'inspire de ta signature : Be root Cliquer ici pour agrandir

  3. #3
    HAVOC Visiteurs

    Par défaut Re : Xorg très lent à lancer !

    Il faudrait que tu postes ton xorg.conf qui se trouve dans /etc/X11/xorg.conf ainsi que ton rc.conf qui se trouve dans /etc/rc.conf.

    Qu'est ce que tu as installé sur ton OpenBox comme goodies ?

  4. #4
    Date d'inscription
    septembre 2009
    Messages
    90
    Remerciements
    1
    Remercié 1 fois dans 1 message
    Pouvoir de réputation
    9

    Par défaut Re : Xorg très lent à lancer !

    As-tu scruté le log du serveur Xorg ?

    Il se trouve ici normalement : /var/log/Xorg.0.log

    Les lignes informatives commencent par (II), les avertissement par (WW) et les erreurs par (EE).

    Commencer par les commandes:

    grep EE /var/log/Xorg.0.log
    grep WW /var/log/Xorg.0.log

    Il faut aussi vérifier le fichier caché .xsession-errors qui se trouve dans le répertoire de l'utilisateur ($HOME)
    Bonne chance.
    Dernière modification par djezzyman ; 26/10/2009 à 12h31.

  5. #5
    Date d'inscription
    mars 2009
    Localisation
    Entre la chaise et le clavier
    Messages
    461
    Remerciements
    0
    Remercié 0 fois dans 0 messages
    Pouvoir de réputation
    9

    GNU/Linux Re : Xorg très lent à lancer !

    Voici mon Xorg.conf :
    Code:
    Section "Device"
        Identifier     "GeForce 7300 SE"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        Option "TripleBuffer" "True"
        Option "AddARGBGLXVisuals"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        Option         "PreferredMode"  "1280x1024"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Monitor        "Monitor0"
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
        Option         "RENDER" "Enable"
    EndSection
    Mon rc.conf ressemble à cela :
    Code:
    #
    # /etc/rc.conf - Main Configuration for Arch Linux
    #
    
    # -----------------------------------------------------------------------
    # LOCALIZATION
    # -----------------------------------------------------------------------
    #
    # LOCALE: available languages can be listed with the 'locale -a' command
    # HARDWARECLOCK: set to "UTC" or "localtime"
    # USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
    # TIMEZONE: timezones are found in /usr/share/zoneinfo
    # KEYMAP: keymaps are found in /usr/share/kbd/keymaps
    # CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
    # CONSOLEMAP: found in /usr/share/kbd/consoletrans
    # USECOLOR: use ANSI color sequences in startup messages
    #
    LOCALE="fr_FR.utf8"
    HARDWARECLOCK="localtime"
    USEDIRECTISA="no"
    TIMEZONE="Africa/Algiers"
    KEYMAP="fr-pc"
    CONSOLEFONT=lat9w-16
    CONSOLEMAP=
    USECOLOR="yes"
    
    # -----------------------------------------------------------------------
    # HARDWARE
    # -----------------------------------------------------------------------
    #
    # MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
    # MOD_BLACKLIST: Prevent udev from loading these modules
    # MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
    #
    # NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
    #
    MOD_AUTOLOAD="yes"
    #MOD_BLACKLIST=()
    MODULES=(!pcspkr)
    
    # Scan for LVM volume groups at startup, required if you use LVM
    USELVM="no"
    
    # -----------------------------------------------------------------------
    # NETWORKING
    # -----------------------------------------------------------------------
    #
    # HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
    #
    HOSTNAME="arch-desktop"
    
    # Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
    #
    # Interfaces to start at boot-up (in this order)
    # Declare each interface then list in INTERFACES
    #   - prefix an entry in INTERFACES with a ! to disable it
    #   - no hyphens in your interface names - Bash doesn't like it
    # 
    # DHCP:     Set your interface to "dhcp" (eth0="dhcp")
    # Wireless: See network profiles below
    #
    eth0="dhcp"
    INTERFACES=(eth0)
    
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   - prefix an entry in ROUTES with a ! to disable it
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(!gateway)
     
    # Enable these network profiles at boot-up.  These are only useful
    # if you happen to need multiple network configurations (ie, laptop users)
    #   - set to 'menu' to present a menu during boot-up (dialog package required)
    #   - prefix an entry with a ! to disable it
    #
    # Network profiles are found in /etc/network.d
    #
    # This now requires the netcfg package
    #
    #NETWORKS=(main)
    
    # -----------------------------------------------------------------------
    # DAEMONS
    # -----------------------------------------------------------------------
    #
    # Daemons to start at boot-up (in this order)
    #   - prefix a daemon with a ! to disable it
    #   - prefix a daemon with a @ to start it up in the background
    #
    DAEMONS=(@syslog-ng @hal @network @crond @alsa @mpd @cups)
    Voici mon autostart.sh sous Openbox :
    Code:
    #!/bin/bash
    nitrogen --restore &
    setxkbmap -layout "fr,ar" -option "grp:alt_shift_toggle" &
    stalonetray -t --dockapp-mode simple &
    parcellite &
    minbar &
    (sleep 30 && conky) &
    liferea &
    Code:
    [tuxargon:~] grep EE /var/log/Xorg.0.log
    Current Operating System: Linux arch-desktop 2.6.31-ARCH #1 SMP PREEMPT Fri Oct 23 11:12:58 CEST 2009 i686
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    [tuxargon:~] grep WW /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    (WW) NVIDIA(0): Option "PreferredMode" is not used
    Je n'ai pas de ~/.xsession-errors

  6. #6
    Date d'inscription
    février 2008
    Localisation
    Alger
    Messages
    1 081
    Remerciements
    84
    Remercié 49 fois dans 37 messages
    Pouvoir de réputation
    12

    Par défaut Re : Xorg très lent à lancer !

    (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    Regarde si acpi est installé sinon :
    Code:
    $ yaourt acpi

  7. #7
    Date d'inscription
    septembre 2009
    Messages
    90
    Remerciements
    1
    Remercié 1 fois dans 1 message
    Pouvoir de réputation
    9

    Par défaut Au sujet de acpi

    Il faut installer le daemon acpid.

    pacman -S acpid

    Ne pas oublier d'ajouter acpid aux autres services du fichier rc.conf.

    Normalement ACPI est actif au niveau du noyau mais s'il faut vérifier:

    dmesg |grep -i acpi

    produit de nombreuses lignes dont la suivante.

    PCI: Using ACPI for IRQ routing

    Bonne chance.
    Dernière modification par djezzyman ; 26/10/2009 à 21h14.

  8. #8
    Date d'inscription
    mars 2009
    Localisation
    Entre la chaise et le clavier
    Messages
    461
    Remerciements
    0
    Remercié 0 fois dans 0 messages
    Pouvoir de réputation
    9

    Par défaut Re : Xorg très lent à lancer !

    Merci.
    Je ressent plus de rapidité en installant acpid et en désactivant l'option "AutoAddDevices" qui repose sur hal Cliquer ici pour agrandir

Discussions similaires

  1. Débit très lent
    Par Redsx dans le forum Easy
    Réponses: 5
    Dernier message: 22/08/2014, 18h56
  2. [Problème] Athir trés lent
    Par Arthur dans le forum Internet via WLL
    Réponses: 15
    Dernier message: 30/12/2009, 12h18
  3. ping tres lent chez Anis
    Par orionstar2009 dans le forum Algérie Télécom
    Réponses: 1
    Dernier message: 10/11/2009, 18h59
  4. Démarrage très lent sur Laptop Toshiba
    Par titeuf15 dans le forum Maintenance et dépannage How-to|Tutos et Docs
    Réponses: 14
    Dernier message: 04/05/2009, 06h57
  5. mon pc trés lent
    Par BEN.YAS dans le forum Windows
    Réponses: 18
    Dernier message: 22/05/2008, 18h16

Les tags pour cette discussion

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •  
[Auto utilitaire DZ] [Webimag] [Algérie Info] [Guide Algérie] [Mosquée ALBADR MEAUX] [Photographe MARIAGE]

is PageRank Checking Icon