Flash sous Linux ? Chrome deviendra obligatoire

mercredi 22 février 2012

Cliquer ici pour agrandir

Adobe vient d'annoncer une nouvelle étonnante : le développement de Flash sous Linux va être lié au développement de Google Chrome. Actuellement, le Flash Player sous Linux utilise d'anciennes API pour se « connecter » à un navigateur, issues de Netscape. Dans le futur, Adobe va utiliser une nouvelle API, nom de code Pepper, pour l'intégration. Et cette nouvelle API est dépendante de Chrome, le navigateur de Google.

Ce que ça implique est assez étonnant : Flash Player 11.2 sera la dernière version compatible avec les API actuelles, mais aussi la dernière version qui sera distribuée par Adobe directement. Si la société s'engage à supporter cette version pendant 5 ans (pour corriger les bugs), toutes les évolutions suivantes ne seront disponibles que via Chrome : Google va continuer à intégrer le Flash Player directement dans le navigateur.

C'est un coup dur pour les autres navigateurs disponibles sous Linux : il faudra obligatoirement installer Chrome pour utiliser le Flash Player, qui reste — quoi qu'on en dise — très utilisé sur Internet. Et Chrome — par son côté propriétaire — est généralement persona non grata dans beaucoup de distributions (comme le Flash Player, du reste).

Espérons qu'Adobe n'ait pas la même idée pour les versions Windows ou Mac OS X du plug-in...

source