Jump to content

Recommended Posts

Salam,

 

Je suis confronté depuis longtemps à un problème assez pénible sur mon archlinux : en effet, le boot depuis grub vers la console ne mets que 8 secondes, je m'authentifie, je lance un startx est là j'attends environ 15 secondes pour avoir le main.

 

Je souligne que je n'utilise pas un un desktop environnement comme gnome ou kde mais un window manager lèger nommé Openbox.

 

J'ai aussi le pilote propriétaires nvidia.

 

Une solution pour rendre ça un peu plus rapide ?

 

Cordialement.

Link to post
Share on other sites

Il faudrait que tu postes ton xorg.conf qui se trouve dans /etc/X11/xorg.conf ainsi que ton rc.conf qui se trouve dans /etc/rc.conf.

 

Qu'est ce que tu as installé sur ton OpenBox comme goodies ?

Link to post
Share on other sites

As-tu scruté le log du serveur Xorg ?

 

Il se trouve ici normalement : /var/log/Xorg.0.log

 

Les lignes informatives commencent par (II), les avertissement par (WW) et les erreurs par (EE).

 

Commencer par les commandes:

 

grep EE /var/log/Xorg.0.log

grep WW /var/log/Xorg.0.log

Il faut aussi vérifier le fichier caché .xsession-errors qui se trouve dans le répertoire de l'utilisateur ($HOME)

Bonne chance.

Edited by djezzyman
Link to post
Share on other sites

Voici mon Xorg.conf :

Section "Device"
   Identifier     "GeForce 7300 SE"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   Option "TripleBuffer" "True"
   Option "AddARGBGLXVisuals"
EndSection

Section "Monitor"
   Identifier     "Monitor0"
   Option         "PreferredMode"  "1280x1024"
EndSection

Section "Screen"
   Identifier     "Screen0"
   Monitor        "Monitor0"
EndSection

Section "Extensions"
   Option         "Composite" "Enable"
   Option         "RENDER" "Enable"
EndSection

 

Mon rc.conf ressemble à cela :

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="fr_FR.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Africa/Algiers"
KEYMAP="fr-pc"
CONSOLEFONT=lat9w-16
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=()
MODULES=(!pcspkr)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="arch-desktop"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(@syslog-ng @hal @network @crond @alsa @mpd @cups)

 

Voici mon autostart.sh sous Openbox :

#!/bin/bash
nitrogen --restore &
setxkbmap -layout "fr,ar" -option "grp:alt_shift_toggle" &
stalonetray -t --dockapp-mode simple &
parcellite &
minbar &
(sleep 30 && conky) &
liferea &

[tuxargon:~] grep EE /var/log/Xorg.0.log
Current Operating System: Linux arch-desktop 2.6.31-ARCH #1 SMP PREEMPT Fri Oct 23 11:12:58 CEST 2009 i686
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
[tuxargon:~] grep WW /var/log/Xorg.0.log
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) NVIDIA(0): Option "PreferredMode" is not used

 

Je n'ai pas de ~/.xsession-errors

Link to post
Share on other sites

Il faut installer le daemon acpid.

 

pacman -S acpid

 

Ne pas oublier d'ajouter acpid aux autres services du fichier rc.conf.

 

Normalement ACPI est actif au niveau du noyau mais s'il faut vérifier:

 

dmesg |grep -i acpi

 

produit de nombreuses lignes dont la suivante.

 

PCI: Using ACPI for IRQ routing

 

Bonne chance.

Edited by djezzyman
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...