Jump to content
Sign in to follow this  
Boss_Med

wll et backtrack 3

Recommended Posts

Guest HAVOC

Salut,

Donc la backtrack étant une slackware on va jouer du slap-get !

Slap-get c'est l'équivalent du du ap-get des debian-like.

 

Pour installer WVDIAL il faut les dépendances suivantes :

wvstreams, libiconv, qdbm, xplc, openslp

 

Pour installer ces packages tu peux utiliser slap-get de cette manière :

slapt-get --update

-> mettre à jour la liste des dépôts

 

slapt-get --upgrade

-> mettre à jour son système (pas obligatoire je pense)

 

slapt-get --search nomDuPackage

-> Tu cherches les différentes dépendances : wvstreams, libiconv, qdbm, xplc, openslp.

 

Quand il t'auras donné le nom exacte du package recherché tu l'installes avec cette commande :

slapt-get --install nomExactePackage

 

Une dois toutes les dépendances installées, tu télécharges WVDIAL version 1.6 ici :

http://repository.slacky.eu/slackware-12.1/network/wvdial/1.60/wvdial-1.60-i686-2bj.tgz

 

(J'ose espérer que la backtrack 3 repose sur une slackware 12.1).

 

Une dois que tu as téléchargé le fichier. tu peux l'installer en tapant :

installpkg wvdial-1.60-i686-2bj.tgz

-> en étant placé dans le même répertoire que le fichier bien entendu.

 

Voilà normalement tout devrait fonctionner.

 

NOTE :

Si tu as des problèmes à installer les dépendances via slap-get, tu peux les installer manuellement comme WVDIAL en téléchargeant leurs fichiers ici :

 

wvstreams :

http://repository.slacky.eu/slackware-12.1/development/wvstreams/4.4.1/wvstreams-4.4.1-i486-1bj.tgz

 

Libiconv :

http://repository.slacky.eu/slackware-12.1/libraries/libiconv/1.12/libiconv-1.12-i486-2as.tgz

 

Qdbm :

http://repository.slacky.eu/slackware-12.1/database/qdbm/1.8.77/qdbm-1.8.77-i486-2as.tgz

 

XPLC :

http://repository.slacky.eu/slackware-12.1/utilities/xplc/0.3.13/xplc-0.3.13-i486-2as.tgz

 

OpenSLP :

http://repository.slacky.eu/slackware-12.1/network/openslp/1.2.1/openslp-1.2.1-i486-2as.tgz

Share this post


Link to post
Share on other sites

Salut,

tout s'est bien déroulé :D j'ai réussi à tout installer merci infiniment mon frère . mais il me reste le port du modem

dmesg -c :

ti_usb_3410_5052 1-2:2.0: TI USB 3410 1 port adapter converter detected

usb 1-2: TI USB 3410 1 port adapter converter now attached to ttyUSB0

puis l'execution

wvdial cdma

--> WvDial: Internet dialer version 1.60

--> Cannot open /dev/ttyUSB0: Protocol error

--> Cannot open /dev/ttyUSB0: Protocol error

--> Cannot open /dev/ttyUSB0: Protocol error

j'ai changé le port vers /dev/ttyS0

wvdial cdma

--> WvDial: Internet dialer version 1.60

--> Initializing modem.

--> Sending: ATZ

--> Sending: ATQ0

--> Re-Sending: ATZ

--> Modem not responding.

pour le fichier de config

[Dialer cdma]

Modem = /dev/ttyS0

Baud = 230400

Init = ATZ

Init2 = AT S11=50

Phone = #777

Username = boss

Password = blabla

PPPD Options = crtcts multilink usepeerdns lock defaultroute

Share this post


Link to post
Share on other sites
Guest HAVOC

Je pense que le problème peut provenir de l'absence du "stupid mode" dans ton fichier config, ce mode permet au modem de compter le # du numéro de téléphone.

 

Essaye ça :

 

[Dialer cdma]

Modem = /dev/ttyUSB0

Baud = 230400

Phone = #777

Init1 = ATZ

Stupid Mode = 1

Dial Command = ATDT

Username = “username”

Password = “password”

PPPD Options = crtcts multilink usepeerdns lock defaultroute

 

Il faut aussi avoir créé le fichier 026_ti_usb_3410.rules pour indiquer à Linux comment utiliser le modem.

Share this post


Link to post
Share on other sites

toujours méme problème

bt ~ # wvdial cdma

--> WvDial: Internet dialer version 1.60

--> Cannot open /dev/ttyUSB0: Protocol error

--> Cannot open /dev/ttyUSB0: Protocol error

--> Cannot open /dev/ttyUSB0: Protocol error

 

PS: j'ai oublié de te dire que backtarack est sous vmware ... à cause du modem je peut pas l'installer..

Share this post


Link to post
Share on other sites
Guest HAVOC
toujours méme problème

 

 

PS: j'ai oublié de te dire que backtarack est sous vmware ... à cause du modem je peut pas l'installer..

 

VMware Workstation ? Il suffit d'activer le partage du port USB cher ami ainsi que du modem :)

Fais un petit tour dans le coté de la config de VMWare ;-)

Share this post


Link to post
Share on other sites

wé c'est déja fait et le partage est tout a fait correct :) la preuve quand je branche le modem et je tape dmesg -c il me dit que le modem est bien branché :)

Share this post


Link to post
Share on other sites
Guest HAVOC
wé c'est déja fait et le partage est tout a fait correct :) la preuve quand je branche le modem et je tape dmesg -c il me dit que le modem est bien branché :)

 

Hummm sur certaines distribution cela nécessite un redémarrage. Mais ta backtrack elle est en lancement via LiveCD ou installé comme OS virtuel ?

Share this post


Link to post
Share on other sites

bon ta raison elle est en live donc à chaque redémarrage un nouveau système

pour l'installation j'ai partitionné et tout est correct je suis sur mais quand je redémarre rien qu'une black screen .

mais au faite pour quoi je doit redémarrer ?

Share this post


Link to post
Share on other sites
Guest HAVOC
bon ta raison elle est en live donc à chaque redémarrage un nouveau système

pour l'installation j'ai partitionné et tout est correct je suis sur mais quand je redémarre rien qu'une black screen .

mais au faite pour quoi je doit redémarrer ?

 

Sincèrement je ne sais pas. J'ai des gens qui ont constaté cela notamment avec Mandriva, le modem n'était pas opérationnel avant un redémarrage de Linux.

 

tu peux installer ta Bakctrack sur un disque virtuel avec ta VMWare au lieu de faire un démarrage en LiveCD sur machine virtuelle.

Share this post


Link to post
Share on other sites
Guest HAVOC

Au fait, tu as installé les dépendances avec slap-get ou installpkg ?

Share this post


Link to post
Share on other sites
Au fait, tu as installé les dépendances avec slap-get ou installpkg ?

 

wé slapt-get ne marchait pas je ne sais pas pourquoi !!!! mais je les ai installé avec installpkg.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...