Jump to content

reconnection d-link DSL-2750U via telnet


Recommended Posts

Bonjour

Parfois on a besoin de changer d'adresse IP surtout pour les téléchargement qui limite ces derniers par adresse IP, avant j'avais un autre modem pour lequel j'avais un petit logiciel qui me permet de me reconnecter, pour le DSL-2750U j'ai beau cherché mais je n'ai rien trouvé, même à travers sa page de commande via http://192.168.1.1/ il n'y a pas un moyen de déconnecter et de connecter sauf si tu choisi lors de la première configuration le mode manuel mais la galère quand tu allume ton modem tu dois te connecter.

Il y a bien sûr la commande reboot dans le menu management mais je la trouve assez lente.

 

Alors en allant voir un peu les commandes sous telnet j'ai trouvé cette possibilité que je veux partager avec vous:

dans une fenêtre cmd ou powershell (sous windows 10 clic droit sur le logo Windows en bas à gauche et choisi ligne de commande ou powershell)

tape telnet 192.168.1.1 (adresse modem)

Login: admin

Password: (tu tape ton mot de passe admin si tu ne l'as pas changé c'est "admin", Attention tu ne vois rien à l'écran il n'y a pas d'étoiles)

tu peux taper un help pour voir toute les commandes si ça t’intéresse sinon voici ce que je propose:

 

wan show (pour voir l'état de ta connexion et ton adresse IP)

wanshow.png

ppp config ppp0 down (pour te déconnecter, attention ppp0 si tu as laissé tout par défaut)

wan show (pour vérifier que tu est bien déconnecté)

wanshow2.png

patienter un petit moment car j'ai remarqué parfois ça bloque, ensuite:

ppp config ppp0 up (pour te connecter de nouveau)

encore un:

wan show (pour vérifier que tu es bien connecté avec une autre adresse IP)

wanshow3.jpg

 

Attention la commande ppp config ppp0 down et ppp config ppp0 up ne donne aucune réponse il faut juste ne pas avoir d’erreur

 

Ce n'est pas top top mais ça me dépanne au lieu d'un reboot complet ou extinction-allumage

 

Je voulais automatiser ça dans un script mais je n'ai pas les compétences pour ça

Si quelqu'un s'en charge se serait un plus

 

NB: j'ai oublié de mentionner que telnet n'est pas actif par défaut sous Windows 10. Suivre ce tuto pour l’intégrer

Le panneau de configuration a été remplacer par paramètre coller ceci "Panneau de configuration\Tous les Panneaux de configuration\Programmes et fonctionnalités" dans la bar d'exploration d'Explorer et vous atteindrez directement l'endroit.

Edited by mbider
oubli
Link to post
Share on other sites

Oui si tu utilise débrancher/rebrancher l'alimentation secteur du modem juste pour changer d'adresse IP.

Sauf qu'avec cette méthode tu ne va pas attendre plusieurs dizaine de secondes pour avoir ton adresse IP tu peux l'avoir en quelques secondes, c'est le but.

Link to post
Share on other sites
  • 1 year later...

Ce n'est pas top top mais ça me dépanne au lieu d'un reboot complet ou extinction-allumage

 

Je voulais automatiser ça dans un script mais je n'ai pas les compétences pour ça

Si quelqu'un s'en charge se serait un plus

 

NB: j'ai oublié de mentionner que telnet n'est pas actif par défaut sous Windows 10. Suivre ce tuto pour l’intégrer

Le panneau de configuration a été remplacer par paramètre coller ceci "Panneau de configuration\Tous les Panneaux de configuration\Programmes et fonctionnalités" dans la bar d'exploration d'Explorer et vous atteindrez directement l'endroit.

*********

bon j'ai un scripte pour l'auto redemarage du routeur en.vbs

 

 

set WshShell = WScript.CreateObject("WScript.Shell")

 

 

'Se connecter au Routeur via son IP

'Ajouter un délai de 0.5 secondes en utilisant le paramètre Sleep 500 après chaque commande

 

 

WshShell.run"telnet.exe 192.168.1.1"

WScript.Sleep 500

 

 

'Donner Utilisateur

 

 

WshShell.SendKeys"le nom de l'authentification"

WshShell.SendKeys("{Enter}")

WScript.Sleep 500

 

 

'Donner Mot de passe

 

 

WshShell.SendKeys"ton mdp"

WshShell.SendKeys("{Enter}")

WScript.Sleep 500

 

 

'Redémarrer le Routeur

 

 

WshShell.SendKeys"reboot"

WshShell.SendKeys("{Enter}")

Link to post
Share on other sites
  • 3 months later...
  • 6 months later...

merci pacus je n'ai pas vu ton message.

 

Voici le script qui convient:

set WshShell = WScript.CreateObject("WScript.Shell")

WshShell.run"telnet.exe 192.168.1.1"

WScript.Sleep 500

WshShell.SendKeys"ton_user{Enter}"

WScript.Sleep 1000

WshShell.SendKeys"ton_password{Enter}"

WScript.sleep 1000

WshShell.SendKeys "ppp config ppp0 down{ENTER}"

WScript.sleep 4000

WshShell.SendKeys "ppp config ppp0 up{ENTER}"

WScript.sleep 500

WshShell.SendKeys "exit{ENTER}"

WScript.sleep 500

WshShell.SendKeys " "

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Posts

    • beaucoup ont eu ce probleme dans la meme intervelle de temps
    • Merci beaucoup @1conito pour tes orientations, j'ai ce modem routeur Asus depuis plusieurs années et je ne me suis jamais rendu sur cet anglet 😞  Et voici le résultat en vous remerciant tous par avance pour votre aide :
    • ça l'air de VRAIMENT "bricoler sur les cables et les config"........... @ZHealer hier, faisait par de la chute de son débit de 17.5 à 10.....!!!!!! https://www.forumdz.com/topic/39665-promotion-recharges-adsl/?do=findComment&comment=326604 est ce  une tendance  ?...........qui confirme qu'AT bricole sur les câbles et les config.......en ce moment, ou juste des incidents localisé (isolés?) sur certains MSAN ?????   Non seulement....... j'ai chuté de 19 Max Rate (pas current) à 13..... Mais ......je suis malheureusement toujours "arrimé" aux "10240"Kpbs current rate, qui donnent un bon 8 et qlqes Mega, loin des 10 Méga payés (Nlle Offre). Ce qui m'a intrigué sur la chute du Max Rate à 13, c'est que les ex-8 Mega, demandent maintenant un current à 12 minimum pour avoir leur 10 réel en DL....... Alors..... Je me suis demandé si c'était pas une erreur de config par un exécutant pied nickelé, au lieu d’élever le current rate à 12, il a mal compris, et a baisser le max rate à 13 !!!!!!! ??????  
    • complètement d'accord wallah !! mais la c de la full incompetence !!! le bonhomme était vraiment largué quand j'ai commencé a parler de Line Rate et de max Line rate ; après il a essayé de me convaincre que c du a aune atteinte physique de la ligne !!! genre bessif !!! wallah c grave 
    • Bonjour, Saha ftourkoum, J'ai un problème de non-accès aux sites hébergés sur free.fr.Comment régler cela ?Merci.
×
×
  • Create New...