Jump to content
Règlement du forum ×
IPTV et arnaques ×

reconnection d-link DSL-2750U via telnet


mbider

Recommended Posts

Bonjour

Parfois on a besoin de changer d'adresse IP surtout pour les téléchargement qui limite ces derniers par adresse IP, avant j'avais un autre modem pour lequel j'avais un petit logiciel qui me permet de me reconnecter, pour le DSL-2750U j'ai beau cherché mais je n'ai rien trouvé, même à travers sa page de commande via http://192.168.1.1/ il n'y a pas un moyen de déconnecter et de connecter sauf si tu choisi lors de la première configuration le mode manuel mais la galère quand tu allume ton modem tu dois te connecter.

Il y a bien sûr la commande reboot dans le menu management mais je la trouve assez lente.

 

Alors en allant voir un peu les commandes sous telnet j'ai trouvé cette possibilité que je veux partager avec vous:

dans une fenêtre cmd ou powershell (sous windows 10 clic droit sur le logo Windows en bas à gauche et choisi ligne de commande ou powershell)

tape telnet 192.168.1.1 (adresse modem)

Login: admin

Password: (tu tape ton mot de passe admin si tu ne l'as pas changé c'est "admin", Attention tu ne vois rien à l'écran il n'y a pas d'étoiles)

tu peux taper un help pour voir toute les commandes si ça t’intéresse sinon voici ce que je propose:

 

wan show (pour voir l'état de ta connexion et ton adresse IP)

wanshow.png

ppp config ppp0 down (pour te déconnecter, attention ppp0 si tu as laissé tout par défaut)

wan show (pour vérifier que tu est bien déconnecté)

wanshow2.png

patienter un petit moment car j'ai remarqué parfois ça bloque, ensuite:

ppp config ppp0 up (pour te connecter de nouveau)

encore un:

wan show (pour vérifier que tu es bien connecté avec une autre adresse IP)

wanshow3.jpg

 

Attention la commande ppp config ppp0 down et ppp config ppp0 up ne donne aucune réponse il faut juste ne pas avoir d’erreur

 

Ce n'est pas top top mais ça me dépanne au lieu d'un reboot complet ou extinction-allumage

 

Je voulais automatiser ça dans un script mais je n'ai pas les compétences pour ça

Si quelqu'un s'en charge se serait un plus

 

NB: j'ai oublié de mentionner que telnet n'est pas actif par défaut sous Windows 10. Suivre ce tuto pour l’intégrer

Le panneau de configuration a été remplacer par paramètre coller ceci "Panneau de configuration\Tous les Panneaux de configuration\Programmes et fonctionnalités" dans la bar d'exploration d'Explorer et vous atteindrez directement l'endroit.

Edited by mbider
oubli
Link to comment
Share on other sites

Oui si tu utilise débrancher/rebrancher l'alimentation secteur du modem juste pour changer d'adresse IP.

Sauf qu'avec cette méthode tu ne va pas attendre plusieurs dizaine de secondes pour avoir ton adresse IP tu peux l'avoir en quelques secondes, c'est le but.

Link to comment
Share on other sites

  • 1 year later...

Ce n'est pas top top mais ça me dépanne au lieu d'un reboot complet ou extinction-allumage

 

Je voulais automatiser ça dans un script mais je n'ai pas les compétences pour ça

Si quelqu'un s'en charge se serait un plus

 

NB: j'ai oublié de mentionner que telnet n'est pas actif par défaut sous Windows 10. Suivre ce tuto pour l’intégrer

Le panneau de configuration a été remplacer par paramètre coller ceci "Panneau de configuration\Tous les Panneaux de configuration\Programmes et fonctionnalités" dans la bar d'exploration d'Explorer et vous atteindrez directement l'endroit.

*********

bon j'ai un scripte pour l'auto redemarage du routeur en.vbs

 

 

set WshShell = WScript.CreateObject("WScript.Shell")

 

 

'Se connecter au Routeur via son IP

'Ajouter un délai de 0.5 secondes en utilisant le paramètre Sleep 500 après chaque commande

 

 

WshShell.run"telnet.exe 192.168.1.1"

WScript.Sleep 500

 

 

'Donner Utilisateur

 

 

WshShell.SendKeys"le nom de l'authentification"

WshShell.SendKeys("{Enter}")

WScript.Sleep 500

 

 

'Donner Mot de passe

 

 

WshShell.SendKeys"ton mdp"

WshShell.SendKeys("{Enter}")

WScript.Sleep 500

 

 

'Redémarrer le Routeur

 

 

WshShell.SendKeys"reboot"

WshShell.SendKeys("{Enter}")

Link to comment
Share on other sites

  • 3 months later...

I am Staff Author at Field engineer which is an On-Demand Marketplace which connects businesses and freelance field engineers in telecom industry. The Fastest Growing Start-up with a Global Workforce in 175 Countries. We have currently 40,000 engineers signed up worldwide.

 

https://www.fieldengineer.com/skills/site-process-automation-engineer-ericsson

Link to comment
Share on other sites

  • 6 months later...

merci pacus je n'ai pas vu ton message.

 

Voici le script qui convient:

set WshShell = WScript.CreateObject("WScript.Shell")

WshShell.run"telnet.exe 192.168.1.1"

WScript.Sleep 500

WshShell.SendKeys"ton_user{Enter}"

WScript.Sleep 1000

WshShell.SendKeys"ton_password{Enter}"

WScript.sleep 1000

WshShell.SendKeys "ppp config ppp0 down{ENTER}"

WScript.sleep 4000

WshShell.SendKeys "ppp config ppp0 up{ENTER}"

WScript.sleep 500

WshShell.SendKeys "exit{ENTER}"

WScript.sleep 500

WshShell.SendKeys " "

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Posts

    • C'est activé dans le routeur, et non dans le modem, je vais essayer de l'activer sur les deux et voir si il y a une différence.  Les torrents "en téléchargement" ne bloquent pas l'internet, c'est le service Stremio qui cause problème et fonctionne que si je limite le nombre de connexions (qui limite ainsi la vitesse à 3 Mo/s sur une connexion 1 Gbps). 
    • Malheureusement ça fonctionne pas. D'abord le F660 que j'ai n'a même pas l'option Bridge, besif j'ai activé l'option lol Après toute cette manœuvre (le tuto), le routeur ne se connecte pas à internet quand je le branche au port sélectionné pour le bridge. Dans le routeur, même avec mes identifiants PPPOE, il ne se connecte pas. 
    • @rachidramone  As-tu activé le protocole UPnP dans le client torrent et le modem?
    • Malheureusement ça bloque toujours même avec le DMZ quand c'est un swamp de seeders avec les torrents que j'utilise (en occurrence, le service Stremio pour regarder mes séries et films). Le seul moyen plausible serait de pouvoir décrypter et modifier le firmware du ZTE F660 pour débloquer l'option bridge, mais le problème se situe dans le fait qu'ils utilisent le PPPOE pour te laisser te connecter au lieu du DHCP comme tout autre fournisseur internet qui se respecte, donc tu est mort, mode bridge impossible.  J'ai lu que dans ce cas, il faudrait investir dans un GPON ONT de qualité, bonne chance pour qu'ils acceptent de "l'ajouter" au serveur, ou autoriser le routeur actuel dans leur serveur. 
    • @youcef17fr STP 1) Entre l'installation proprement dite (physique) et l'activation de la connexion fibre (donc basculement de l'adsl ou vdsl vers la fibre) combien de temps ? 2) L'ONT c'est bien le Huawei OptiXstar HG8145X6-10 ? as tu trouvé comment logger (log in) en superuser = super admin comme le demande @TomiX ici ? Merci !  
×
×
  • Create New...