Jump to content
Sign in to follow this  
Fr0mY0u

[Aide] Ubuntu, se connecter au net par Ad-Hoc

Recommended Posts

Salam!

 

J'ai besoin de l'aide de nos chers geeks ubuntu ;)

 

Alors j'ai deux laptops,

- le premier sous windows est connecté directement a l'ADSL et partage la connexion via Ad-Hoc. (en connectant un autre ordi avec windows, la connexion marche...)

- le deuxieme sous ubuntu. J'ai bien configuré la carte wifi en Ad-hoc et aussi les adresses Ip. J'ai aussi paramétré les DNS. La connexion est bien établi entre les deux laptop. J'ai le status "connecté" dans les deux ordis.

Mais...

Impossible d'acceder au net a partir d'ubuntu :(

 

Je peux par contre pinger l'ordinateur avec windows.

 

Un petite aide svp :)

Share this post


Link to post
Share on other sites

Si la connexion & ping marchent c'est déjà ça, tu peux nous afficher ta config IP sur les 2 PCs ?

DNS, passerelle....ça aiderait sûrement à t'aider :)

Edited by mouradski

Share this post


Link to post
Share on other sites
Guest HAVOC

sur le latop, il faut paramétré la passerelle avec l'IP du PC connecté au net.

Share this post


Link to post
Share on other sites

:) vous avez raison, ma description n'est pas assez claire...

 

PC 1 - Windows

IP Address. . . . . . . . . . . . : 192.168.0.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

 

PC 2 - Ubuntu

IP : 192.168.0.2

Subnet Mask : 255.255.255.0

Passerelle par défaut : 192.168.0.1 (je l'avais déja fait HAVOC ;) )

DNS:41.221.20.4

Je précise que j'ai aussi fait: iwconfig wlan0 mode Ad-Hoc.

Edited by Fr0mY0u

Share this post


Link to post
Share on other sites

juste avant que j'aille sous ubuntu

comment on change les DNS manuellement? avec le terminal

 

Parce que je n'ai pas tro cpnfiance graphiquement...

Share this post


Link to post
Share on other sites
essaies de mettre l'@ IP du DNS sur le 2eme PC (Ubuntu) sur 192.168.0.1 (ie la passerelle elle même)

 

Merci!! ca a marché... enfin hier seulement.

 

Ce matin impossible :(

 

En tout cas le probleme de DNS est réglé :)

 

Choukrane

Share this post


Link to post
Share on other sites
Merci!! ca a marché... enfin hier seulement.

 

Ce matin impossible :(

 

En tout cas le probleme de DNS est réglé :)

 

Choukrane

 

De rien l'ami :)

 

est-ce que le voyant vert sur le connecteur du PC est au vert (liaison OK!!) ??? ça m'est déjà arrivé qu'après reboot sous un Win ça ne marche plus sou Ubuntu, c'était un problème lié au hard et à l'Ethernet, j'ai reglé le problème en activant un truc sur les options Ethernet dans la config Bios. (Ethernet integré)...

 

essaies et dis nous.

Share this post


Link to post
Share on other sites

Merci beaucoup!

 

Le probleme c'était un bug parce que quand on redemarre la carte wifi ne se remet pas automatiquement en mode Ad-Hoc.

 

Est-ce que vous savez comment faire pour que a chaque demarrage on est en mode Ad-Hoc?

Share this post


Link to post
Share on other sites

tu peux le mettre dans les options du module, dans un fichier de modprobe.d. ca dépend du chipset de ta carte, et si le module linux utilisé supporte l'option ad-hoc, ce qui est plutot rare...

pourquoi ne pas mettre la carte sur ta machine windows en mode master, simplement?

avec madwifi, c'est une chose assez simple: transformer un pc en point d'access.

Share this post


Link to post
Share on other sites
Guest HAVOC

Effectivement, mieux faut une architecture en infrastructure (avec une carte en mode master et l'autre comme client) plutôt que le monde ad-hoc, cela sera normalement plus stable d'ailleurs. Reste à savoir si le driver Windows de ta carte wifi permet de faire ça.

Share this post


Link to post
Share on other sites

justement a part quelques cartes sous windows, on ne peut pas utiliser le mode infrastrure pour partager sa connexion... (Asus le permet...)

 

j'ai une carte Intel Pro Wireless 3945 ABG et le mode Ad-Hoc est supporté puisque je l'utilise actuellement.

Share this post


Link to post
Share on other sites

tu as une carte madwifi sous linux (madwifi supporte le mode master), alors pourquoi ne pas faire le contraire? faire de ta boite linux le gateway (ce serait beacoup plus sécurié au passage)

Share this post


Link to post
Share on other sites

bidossessi est-ce que tu peux me guider stp?

 

tu me dis que ma carte peut etre en mode master sous linux non?

et juste avant tu me dis que je peux le faire avec madwifi sous windows ?

Share this post


Link to post
Share on other sites

ce que je te propose est de faire de ta boite ubuntu ton gateway , et de mettre ta carte wifi atheros en mode master (tu seras limité à l'encryption WEP, donc fais attention aux priates). avec un serveur dhcp associé à ta carte atheros, tu as un gateway résidentiel efficace et opensource!

je n'utilise pas ubuntu, donc je ne pourrais pas te dire quel package télécharger. je suppose qu'il y a des tutos ICS pour ubuntu sur internet.

bonne chance

Share this post


Link to post
Share on other sites

Je n'arrive pas à me connecter en ad-hoc sur un XP doté d'une clé USB 802.11b, entre Vista et XP ça marche très bien mais sous Ubuntu walou !!

 

Le signal lors de la connexion du réseau est à 97% mais descend à zéro quelques secondes plus tard :(

 

Je suis sous Ubuntu 8.10 / 2.6.27.11.

 

 

Pas d'idées ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...