Jump to content

Problème avec mon serveur VPN PPTP


Recommended Posts

Bonjour à tous,

 

Je viens d'installer un serveur VPN PPTP sous Debian sur mon serveur dédié. L'adresse d'accès est la suivante :

 

vpn.livedz.com

 

Le port 1723/tcp open pptp est bien ouvert

 

J'arrive à me connecter dessus avec le compte que j'ai créé mais je n'arrive pas à naviguer sur le net via la connexion VPN.

 

Par contre lorsque je tape l'IP du serveur http://87.98.151.139/ via la connexion VPN, j'arrive à accéder au serveur Apache interne qui m'affiche la page web par défaut.

 

ça doit être une question de DNS ou de routage non ?

Si vous avez une idée ou une supposition merci de m'en faire part.

 

Réfléchir seul, ça ne m'aide pas beaucoup ;)

 

Salutations amicales

Link to post
Share on other sites
  • Moderators

Woulah tu n'arrêtes pas de nous étonner avec tes tests :)

 

Par contre lorsque je tape l'IP du serveur http://87.98.151.139/ via la connexion VPN, j'arrive à accéder au serveur Apache interne qui m'affiche la page web par défaut.

 

ça doit être une question de DNS ou de routage non ?

 

Juste pour signaler qu'en tapant http://vpn.livedz.com/ sur mon navigateur j'arrive à accéder à ta page par défaut.

Welcome to nginx!

Link to post
Share on other sites
Woulah tu n'arrêtes pas de nous étonner avec tes tests :)

Juste pour signaler qu'en tapant http://vpn.livedz.com/ sur mon navigateur j'arrive à accéder à ta page par défaut.

Welcome to nginx!

 

Saha Mouradski_21,

 

Oui c'est tout à fait normal que tu puisse accéder à la page par défaut lorsque tu saisie cette URL sur ton navigateur :)

 

J'ai configuré un "Catch All DNS" ce qui fait que *.livedz.com redirigera automatiquement vers le seul et unique endroit.

 

D'ailleurs, tape mouradski21.livedz.com ou boutaztozi.livedz.com tu seras redirigé vers la même page :)

 

Ce n'est pas ça qui me pose de soucis pour le moment :) c'est fait exprès :)

 

Maintenant, lorsque je me connecte sur le serveur voici ce que ça m'affiche :

 

Ce qui m'intéresse c'est l'interface ppp0 du serveur :

 

~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:xxxxxxxxxxxxxxxxxxxxx  
        [b] inet addr:91.121.192.75[/b]  Bcast:91.121.192.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:52837 errors:0 dropped:0 overruns:0 frame:0
         TX packets:35031 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000 
         RX bytes:64123864 (61.1 MiB)  TX bytes:12307132 (11.7 MiB)
         Interrupt:19 Base address:0x2000 

eth0:0    Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxxxxxxx  
        [b] inet addr:87.98.151.139[/b]  Bcast:87.255.255.255  Mask:255.255.255.255
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         Interrupt:19 Base address:0x2000 

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:3368 errors:0 dropped:0 overruns:0 frame:0
         TX packets:3368 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0 
         RX bytes:141472 (138.1 KiB)  TX bytes:141472 (138.1 KiB)

[b]ppp0      Link encap:Point-to-Point Protocol  
         inet addr:87.98.151.139  P-t-P:192.168.0.234  Mask:255.255.255.255[/b]
         UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1496  Metric:1
         [b]RX packets:6 [/b]errors:0 dropped:0 overruns:0 frame:0[b]
         TX packets:6 [/b]errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:3 
         RX bytes:102 (102.0 b)  TX bytes:96 (96.0 b)

A chaque fois qu'un utilisateur se connecte avec son compte sur le serveur VPN, ce dernier lui attribue une IP locale allant de 192.168.0.0 à 192.168.0.254

 

Or là, j'ai l'adresse 192.168.0.234 avec un routage vers l'IP fixe publique du serveur 87.98.151.139

C'est en somme la situation actuelle des choses.

Lorsque je suis connecté comme ça et que je saisi : www.google.fr je suis rejeté comme s'il ne trouvait pas google.fr

 

Donc j'ai supposé un problème de résolution de nom (donc de DNS) et j'ai essayé de taper l'IP de Google : même chose, il ne trouve rien.

 

Mais lorsque je tape http://87.98.151.139 j'ai ma page Nginx qui s'affiche.

 

Donc c'est comme si il y avait une connexion que vers le local ou vers cette IP mais pas vers l'extérieur.

 

Bizarre je continue mes tests :) merci en tous cas Mouradski_21 :)

 

 

 

Link to post
Share on other sites
Bonjour à tous,

 

Je viens d'installer un serveur VPN PPTP sous Debian sur mon serveur dédié. L'adresse d'accès est la suivante :

 

vpn.livedz.com

 

Le port 1723/tcp open pptp est bien ouvert

 

J'arrive à me connecter dessus avec le compte que j'ai créé mais je n'arrive pas à naviguer sur le net via la connexion VPN.

 

Par contre lorsque je tape l'IP du serveur http://87.98.151.139/ via la connexion VPN, j'arrive à accéder au serveur Apache interne qui m'affiche la page web par défaut.

 

ça doit être une question de DNS ou de routage non ?

Si vous avez une idée ou une supposition merci de m'en faire part.

 

Réfléchir seul, ça ne m'aide pas beaucoup ;)

 

Salutations amicales

 

It's not DNS it's routing. Make sure your internet gateway is the default gateway and add static route to your VPN.

Edited by Darkvader
Link to post
Share on other sites
  • Moderators

 

D'ailleurs, tape mouradski21.livedz.com ou boutaztozi.livedz.com tu seras redirigé vers la même page :)

 

 

Mais lorsque je tape http://87.98.151.139 j'ai ma page Nginx qui s'affiche.

 

Donc c'est comme si il y avait une connexion que vers le local ou vers cette IP.

 

 

lol :D

 

Dsl d'inciter bof mais mouradski21.live.com tout comme livedz.com donne sur la même page du moins en HTML ça done ça :

 

Welcome to LiveDZ!

 

Propulsé par Nginx!

 

 

par contre vpn.livedz.com

 

ça donne ça en HTML :

Welcome to nginx!

 

donc y'a bien une petite différence entre nimportequoi.livedz.com et vpn.livedz.com.

 

Mais comme ça doit surement être du dynamique je crois qu'on est sur la même page php :D

 

je me doute que ça ne va pas beaucoup t'aider mais juste pour signaler lol :D

 

Bonne continuation :)

Link to post
Share on other sites
It's not DNS it's routing. Make sure your internet gateway is the default gateway and add static route to your VPN.

 

route add default ppp0

 

Here is my network at home :

 

http://picasaweb.google.com/freefoxtv/FreeFoxTV?feat=embedwebsite#5285466920308933986

 

And I gave you information about the dedicated server on the previous post :)

 

What do you mean by "adding static route to the VPN ?

Thanks Darkvador ;)

 

lol :D

 

Dsl d'inciter bof mais mouradski21.live.com tout comme livedz.com

 

Welcome to LiveDZ!

 

Propulsé par Nginx!

 

 

par contre vpn.livedz.com

 

ça donne ça en HTML :

Welcome to nginx!

 

donne sur la même page du moins en HTML ça done ça :

donc y'a bien une petite différence entre nimportequoi.livedz.com et vpn.livedz.com.

 

Mais comme ça doit surement être du dynamique je crois qu'on est sur la même page php :D

 

je me doute que ça ne va pas beaucoup t'aider mais juste pour signaler lol :D

 

Bonne continuation :)

 

C'est seulement ton cache qui te renvois la page Nginx :) vérifie tu verras.

 

Salam,

 

Ca ne doit pas etre un pb de DNS, pour en être sur essaye apres connection vpn de lancer la page http://209.85.171.100 au lieu de http://www.google.com

 

Ne faut-il pas un truc du genre pour activer le forward ?

echo 1 > /proc/sys/net/ipv4/ip_forward

 

C'est déjà fait et activé assilabox

Voici un tuto similaire que j'ai suivis http://blog.gamecg.eu/?p=19

 

J'ai rajouté un routage avec iptable du style :

 

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/24 -j SNAT --to 87.98.151.139

 

Merci à tous, je continue les tests :)

Link to post
Share on other sites

what is in the pptp.conf? I mean the localip and remoteip

 

the remoteip shouldn't be bound on the the vpn server, it needs to be free.

 

also you need to set this up

 

iptables -A FORWARD -i ppp+ -o eth0 -j ACCEPT

iptables -A FORWARD -i eth0 -o ppp+ -j ACCEPT

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

 

 

also these needs to be allowed for the port 1723 and protocol 47

iptables -a INPUT -i eth0 -p tcp --dport 1723 -j ACCEPT

iptables -A INPUT -i eth0 -p gre -j ACCEPT

Edited by Darkvader
Link to post
Share on other sites
what is in the pptp.conf? I mean the localip and remoteip

 

localip 87.98.151.139

remoteip 192.168.0.234-238,192.168.0.245

 

 

the remoteip shouldn't be bound on the the vpn server, it needs to be free.
concerning the remoteip, I have no idea actually. For me the local remoteips are IPs generated virtually by the VPN, no ?

 

also you need to set this up

 

iptables -A FORWARD -i ppp+ -o eth0 -j ACCEPT

iptables -A FORWARD -i eth0 -o ppp+ -j ACCEPT

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

 

 

also these needs to be allowed for the port 1723 and protocol 47

iptables -a INPUT -i eth0 -p tcp --dport 1723 -j ACCEPT

iptables -A INPUT -i eth0 -p gre -j ACCEPT

This part is okay, I've already opened 1723 and gre :

 

iptables -a INPUT -i eth0 -p tcp --dport 1723 -j ACCEPT

iptables -A INPUT -i eth0 -p gre -j ACCEPT

 

But I think I did someting wrong with the routing in fact. I'll try what you suggested to me :)

 

Thanks Darkvader

Link to post
Share on other sites
localip 87.98.151.139

remoteip 192.168.0.234-238,192.168.0.245

concerning the remoteip, I have no idea actually. For me the local remoteips are IPs generated virtually by the VPN, no ?

 

your remoteips are fine as long as they are not bound to other machines, that's what I meant by free.

Link to post
Share on other sites
localip 87.98.151.139

remoteip 192.168.0.234-238,192.168.0.245

 

 

concerning the remoteip, I have no idea actually. For me the local remoteips are IPs generated virtually by the VPN, no ?

 

This part is okay, I've already opened 1723 and gre :

 

iptables -a INPUT -i eth0 -p tcp --dport 1723 -j ACCEPT

iptables -A INPUT -i eth0 -p gre -j ACCEPT

 

But I think I did someting wrong with the routing in fact. I'll try what you suggested to me :)

 

Thanks Darkvader

 

Have you got it to work yet?

Link to post
Share on other sites
  • 3 weeks later...

Bonjour

 

C'est un problème de routage et de NAT; pourriez vous poster le résultat de route -n sans le VPN; et après une connexion VPN;

 

Juste une question : pourquoi voulez vous vous connecter au serveur via PPTP? y a t il un réseau privé sur le serveur? Si c'est pour vous connecter avec l'IP du Serveur, c'est un bon test à faire ;) .

 

 

Merci

Edited by utee
Link to post
Share on other sites

bon, j'ai pas tout lu ....

 

Il s'agit d'un problème de route, en te connectant au VPN, ta machine fera partie de ce reseau et si ce dernier n'a pas d'accès à internet alors tu n'en auras pas non plus. Il faut que tu ajoutes une route vers un reseau qui en dispose en precisant l'ip qui t'a été attribuée par le serveur VPN.

Link to post
Share on other sites
  • 2 months later...

j'ai aussi un vpn sur un dédié mais le problem qui se pose c'est que je n'arrive pas a accédé au réseaux lan du client connécté en vpn .

 

en gros je voudrais que le "client 2" puissent ce connécté sur le serveur web qui ce trouve dans le "pc2" du réseaux local du "client 1" , je sais que je doit redirigé la connection depuis l'interface ppp vers eth0 mais je ne sais pas comment je suis un peut perdu donc toute information est la bienvenu , merci d'avance .

 

sachant que , (pc2) et (pc3) sont connécté en lan. et et en VPN.

 

-------------------------(pc2)-----------|---------(pc3)

|

|

|

|

|-----

 

client1: 192.168.1.2(lan), 192.168.0.235 (vpn)

client2 :192.168.1.2(lan), 192.168.0.234 (vpn)

pc2 et pc3 : 192.168.1.3, 192.168.1.2

Edited by djawed
Link to post
Share on other sites

Salut djawed,

 

Pour ma part j'ai complètement abandonné cette idée de serveur VPN PPTP. J'ai essayé de me mettre à OpenVPN mais ce n'est pas encore gagné.

 

Je reviendrai certainement un jour pour tester OpenVPN en local d'abord avant de faire quoi que ce soit sur le serveur dédié.

 

Sinon pour OpenVPN sous GNU/Linux, je vous conseille : http://www.nbs-system.com/dossiers/howto-openvpn2.html

 

Salutations amicales et bon courage.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Posts

    • Au secours ! J'ai acheté a l'instant le iron pro..après activation des plugins tnt et orca qui se passent bien... He bien aucune chaine ne fonctionnent ni sur eutelsat ni sur nilesat !! Il n'y a que les chaînes en clair qui passent ! C'est quoi cette foutaise les amis ? @didiss ?
    • Au secours ! J'ai acheté a l'instant le iron pro..après activation des plugins tnt et orca qui se passent bien... He bien aucune chaine ne fonctionnent ni sur eutelsat ni sur nilesat !! Il n'y a que les chaînes en clair qui passent ! C'est quoi cette foutaise les amis ?
    • ta essayé de convertir ton ancien modem en point d'accès ? pour amélioré encore plus la porté du wifi a la maison ? 
    • bonjour les gars que pensez-vous du Dlink dsl-124 ? je viens de l'acheter pour remplacer mon ancien SITEL 114w d'AT et son wifi faiblard des réglages particuliers à faire sur ce Dlink 124 ?
    • bonjour finalement sur conseil j'ai acheté un nouveau modem , le Dlink 124 avec meilleurs portée du wifi que mon ancien SITEL d'AT ... et ça à l'air de regler le problème ça m'a couté 4000 DA  , moins cher de remplacer mon modem que de garder l'ancien et d'investir dans un répéteur ou point d'accés
×
×
  • Create New...