Jump to content
parazitenew

Cherche XDA Developers Algérien

Recommended Posts

Bonsoir,

 

Connaissez vous un forum actif de préférence Algérien (car les forums FR que je connais ne traitent plus des anciens smartphones) à l'allure de XDA, car même sur XDA c'est mort, j'ai posté un sujet il y a quelques jours et il n'a été vu que 26 fois.

 

Je galère sur un truc, j'arrive plus à dormir, j'ai raté 2 demi journées de travail à cause de ce problème, bref, il faut que j'aie une réponse car là ça va eme bouffer la vie.

 

PS: Vraiment je cherche des AS

Share this post


Link to post
Share on other sites

@abdelkader31, oui, mais il a évolué depuis :D

 

expose ton problème ici, peut être qu'on t'aidera :D

 

C'est assez hard comme problème, mais je vais tenter.

 

Bonne lecture :D

 

J'ai acheté un LG Optimus 3D (P920) à un prix bas, car il avait un problème de bootloop. Ayant déjà flashé, brické, débrické, customisé mon LG Optimus Black (P970), je me suis dis que je devrais sans problème régler le O3D et j'aurais gagné un nouveau smartphone.

 

Tout de suite je me suis aperçu que même si le principe est le même, les étapes ne le sont pas. J'ai donc bossé tout les topics de XDA sur le sujet.

 

Après de nombreuses tentatives, le LG O3D avait enfin démarré sous ICS 4.0.4 que je lui avais flashé. La V30A. J'étais content, mais c'est là que le cauchemar commence:

 

 

  • La camera ne marche pas, lorsque je rentre dans la cam, elle se ferme toute seule.
  • Le lecteur de musique se ferme tout seul.
  • Pas de son.
  • Google Play se ferme tout seul
  • Les applications utilisant la cam ne démarrent pas avec le message "Impossible d'établir la connexion avec l’appareil photo"
  • Si le téléphone entre en veille, il n'en sort pas. Sauf s'il est branché sur le chargeur, là il peut être sortit de veille normalement avec le bouton de démarrage.

 

Avec une manipulation spécifique, j'ai pu le flashé pour que la cam marche mais:

 

  • Le bouton (l'icon) qui devait activer la cam frontale, ne le fait pas. Au lieu de ça, sur l'écran je voyais tjrs ce qu'affichait la cam arrière mais l'image était dupliquée (le LG O3D a deux cam arrières) je voyais donc ce que chaque caméra filmait cote à cote. Alors que normalement c'est un autre bouton qui le fait.

 

Je décide donc de le downgrade sous GB ou même Froyo, mais ça ne marche pas. Le tel ne boot même pas.

 

Après des recherches je découvre que les partitions de la ROM n'étaient pas les même pour ICS et pour les version antérieur. Il fallait donc recréer les partitions de GB, la seule ROM qui peut le faire est la V21E. Avec LG Flash Tool. C'est ce que j'ai fait. Le soucis c'est que ça ne marche pas, le flash s’interrompe. JE décide donc de le faire avec Smart Flash. ça fonctionne mais le tel ne boot pas. Après des recherches, je découvre qu'il faut un bootloader spécifique. Ceux de Berni (un dev de XDA) je les télécharge et je les flash (x-loader et u-boot), le tel boot, mais il bootloop. J'ai essayé par dessus de mettre la V20E la V10L (Froyo) toujours le bootloop.

 

Je repasse sur ICS V30C mais cette fois ci je mets celle du P925 (la version canadienne), le tel boot normalement mais toujours le problème de la cam et de la mise en veille. (je précise que j'ai même tenté le SU760, la version coréenne)

 

Je décide donc de mettre une custom ROM. 100% des customs roms de XDA ne sont pas téléchargeables (liens morts) on aurait dit un complot, pareil sur d'autres forums/sites, la seule ROM dispo en téléchargement est la cm7.2.0 ,cyanogenmod version GB.

 

Depuis ICS je root le tel depuis le recovery, je fais les 3 wipe et là je lance le zip de la cm, surprise, erreur status 7

 

assert failed: getprop("ro.product.device") =="p920"

 

Je dézip la rom sous le PC, et je modifie la ligne de vérification de l'appareil pour forcer l'installation, je sauvegarde, je retourne sur le recovery, j’installe, je reboot et la écran noir avec le logo LG et la ligne suivante en haut à gauche de l'écran:

 

boot:mmc_read 0x64adbd

 

Comme ci le tel n'était pas un P920 alors qu'il est. J'ai pensé à une modif du model number mais ce n'est pas ça, puisque sous ICS le getprop qui se trouve dans la ROM d'ailleurs contient bien "p920".

 

Souci de partition peut être, puisque la cm7 est une GB, je retente le V21E, suivie de la cm7, rien, j'ai laissé tombé. J'ai fait tout ça depuis samedi, je veille jusqu'à 3h30, ça me prend la tête, je n'arrive pas à accepter le fait que je n'arrive pas à régler ce problème surtout que je ne comprends pas d'où ça vient.

 

Topics suivis:

http://forum.xda-developers.com/showthread.php?t=2337545

http://forum.xda-developers.com/showthread.php?t=1942836

http://forum.xda-developers.com/showthread.php?t=2246001

http://forum.xda-developers.com/showthread.php?t=2104955

 

et y en a d'autres.

Share this post


Link to post
Share on other sites

un soucis de mmc peut etre, un soucis material, les problemes repetitifs m font pensé a ca

Share this post


Link to post
Share on other sites

je dirais +1 avec clock mais essaie ce qui suit

déjà essaie d'être au max à jour coté recovery (que ce soit TWRP ou CWM ou autre)

ensuite pour l'erreur 7 je vois que tu as dézzipé toute l'archive (chose qu'il faut éviter de faire)

extrais seulement "updater-script" qui se trouve dans "/META-INF/com/google/android/" fais tes modifs et remets le dans l'archive (de préférence une copie, histoire de garder l'originale)

si ça ne marche toujours pas sur GB ou froyo, ça confirmera l'hypothèse du problème matériel

PS: si tu peux flasher une CM, ICS ça reste un bon test

PS2: LG Flash Tool est assez instable, des fois tu as l'impression qu'il est bloqué alors que non, il bosse encore. assure toi qu'il soit bien configuré (j'ai un LG et je peux te dire que niveau soft de bidouille c'est la m****)

Share this post


Link to post
Share on other sites
je dirais +1 avec clock mais essaie ce qui suit

déjà essaie d'être au max à jour coté recovery (que ce soit TWRP ou CWM ou autre)

ensuite pour l'erreur 7 je vois que tu as dézzipé toute l'archive (chose qu'il faut éviter de faire)

extrais seulement "updater-script" qui se trouve dans "/META-INF/com/google/android/" fais tes modifs et remets le dans l'archive (de préférence une copie, histoire de garder l'originale)

si ça ne marche toujours pas sur GB ou froyo, ça confirmera l'hypothèse du problème matériel

PS: si tu peux flasher une CM, ICS ça reste un bon test

PS2: LG Flash Tool est assez instable, des fois tu as l'impression qu'il est bloqué alors que non, il bosse encore. assure toi qu'il soit bien configuré (j'ai un LG et je peux te dire que niveau soft de bidouille c'est la m****)

 

Je n'ai pas tout dézippé, juste le script en question.

 

Je vais tenter la cm10

 

Salut, essaie de flasher la dernière nightly de CM 10 : https://download.cyanogenmod.org/?device=p920

 

ou bien: cette ROM là: http://www.needrom.com/download/lg-optimus-3d-2/

 

 

J'ai vérifié les liens, et ça marche.

 

Ok.Alors voilà, je l'ai fait passer sous ICS stock V30A, je l'ai rooté (via le recovery, car avec les logiciels de root ça ne marche pas parce que le tel ne redémarre pas après, j'ai remarqué ça aussi en installant les rom kdz, le tel est sensé redémarrer tout seul après la MAJ mais il ne le fait, je le fait manuellement) J'ai effectué les wipe puis j'ai lancé la cm-10-nightly; résultat:

 

Finding update package...

Opening update package...

Installing update...

assert failed: getprop("ro.product.device") == "

E:Error in /emmc/cm10-10-20131006-NIGHTLY-p920.zip

(Status 7)

 

* Verifying filesystems...

* Verifying partition sizes...

Error flashing zip '/emmc/cm10-10-20131006-NIGHTLY

 

Pareil.

Share this post


Link to post
Share on other sites
tu utilises quoi comme recovery ?

 

 

Pour ce qui est de lg flashtool, voici un lien qui marche: https://www.androidfilehost.com/?fid=23501681358553917

 

 

Pour ton problème:

Je pense qu'il faut mettre à jour ton recovery, si j'ai bien compris, c'est de CWM qu'il s'agit, voilà la dernière MAJ:

http://d-h.st/QEP

 

 

Sinon, voilà CM11 et tente le coup aussi avec!

http://forum.xda-developers.com/optimus-3d/development/rom-t2929971

 

 

 

Edited by sympho

Share this post


Link to post
Share on other sites

J'ai utilisé le TWRP 2.2.2.1 et le CWM 6.0.1.5 (même message d’erreur)

Pour le CWM 6.0.2.6 le tel ne peut pas boot dessus.

 

En installant la cm11 je lis ceci:

 

Installing update...

This package is for "p920" devices; this is a "cosmopolitan".

E:Error in /emmc/cm-11-20141110-UNOFFICIAL-p920.zip

(Status 7)

Installation aborted.

Share this post


Link to post
Share on other sites

le cosmopolitan c'est le LG-SU760

je commence à perdre le fil :D tu as un SU760 ou un P920 ? en sachant que la rom de l'un ne va pas (ou pas forcément) sur l'autre

Share this post


Link to post
Share on other sites
le cosmopolitan c'est le LG-SU760

je commence à perdre le fil :D tu as un SU760 ou un P920 ? en sachant que la rom de l'un ne va pas (ou pas forcément) sur l'autre

 

Oui je sais qu'ils ne sont pas compatibles, le SU760 est la version coréenne, mais celui que j'ai est sensé être un P920 (C'est écris sur l'étiquette collé sur le tel sous la batterie, et la coque est celle d'un P920).

 

http://www.heberger-image.fr/images/50748_IMG207.jpg.html

 

http://www.heberger-image.fr/images/34528_IMG208.jpg.html

 

Pourquoi donc le tel se croit être un SU760?? À moins que celui qui me la vendu a changer un truc et il ne me l'a pas dit (genre changer la coque, ou la carte mère ou je sais pas quoi). Si c'est le cas ça expliquerai pourquoi les ICS ne marchent pas bien, et pourquoi GB ne boot pas. Mais faudrait une preuve tangible.

Share this post


Link to post
Share on other sites

Ceci

Je repasse sur ICS V30C mais cette fois ci je mets celle du P925 (la version canadienne), le tel boot normalement mais toujours le problème de la cam et de la mise en veille. (je précise que j'ai même tenté le SU760, la version coréenne)

 

peut aussi expliquer cela

Pourquoi donc le tel se croit être un SU760??

 

je connais quelqu'un qui a eu la même mésaventure avec un S3 américain (i747) et qui a été flashé avec une rom de S3 international (i9300), ça a foutu le boxon sur les partitions ... etc

il a fallu s'armer bien sur d'une ROM officielle, du bootloader/modem et du fichier *.pit spécialement pour ce modèle pour restructurer les partitions (je ne sais pas si c'est seulement chez Sammy ou même chez LG)

 

pour être fixer à 100% flash une rom (qui boot :p ) et essaie d'installer l'appli cpu-z (en offline si tu n'as pas accès au playstore) ça devrait te filer tout un tas d'informations ;)

Share this post


Link to post
Share on other sites

Très bien, actuellement il est en V30A ça boot. Mais je ne peux pas passer par le playstore il se ferme tout seul. Je ne peux pas installer des apk parce-que justement je ne peux pas installer d'explorer, Comment puis-je installer cpu-z via le recovery?

 

PS: J'ai une ROM V30B (.kdz ou .fls et .bin)du SU760 que j'avais testé, le tel n'a pas booté, j'ai aussi des bootloaders du SU760

Edited by parazitenew

Share this post


Link to post
Share on other sites
Très bien, actuellement il est en V30A ça boot. Mais je ne peux pas passer par le playstore il se ferme tout seul. Je ne peux pas installer des apk parce-que justement je ne peux pas installer d'explorer, Comment puis-je installer cpu-z via le recovery?

 

PS: J'ai une ROM V30B (.kdz ou .fls et .bin)du SU760 que j'avais testé, le tel n'a pas booté, j'ai aussi des bootloaders du SU760

 

Utilise uniquement du P920 (on va aller dans le sens ou ça en est un)

Share this post


Link to post
Share on other sites

on est maintenant sûr que tu as un P920 :D

maintenant tu dois suivre à la lettre les instructions pour le P920 (uniquement) de ce topic (que tu as déjà lu) >>>ICI

Share this post


Link to post
Share on other sites

Si cpuz lis les infos à partir de la rom ou les données générées par la rom ça ne prouve rien.

 

Je l'avais déjà fait plusieurs fois ce tuto :s et c'est au niveau de LGflashtool que ça coince. Il dit qu'après le premier echec le mode S/W devrait être dispo sans fastboot, or ce n'est pas le cas pour moi. Là je suis sous cm9 SU760. ça a boot mais la cam ne s'ouvre pas et y a pas de son. dans les infos du tel je lis "model number: SU760" Voilà pourquoi je me dis que cpuz n'est peut être pas fiable.

 

Je vais retenter le coup avec ce tuto et on verra.

Edited by parazitenew

Share this post


Link to post
Share on other sites

dans les infos du tel, c'est un fichier généré qui est lu, tu peux mettre "model number : parazitenew" et version android idem, normal.

par contre CPU-Z est censé interrogé le matériel directement, si tu veux en avoir le coeur net, test le sur la su760 si tu l'as toujours (mais si c'est un P920) je te déconseille de flasher autre chose que des ROM pour ce modèle :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...