Jump to content
Salima_Anissa

problème avec PHBB FORUM VERSION 2 OU 3

Recommended Posts

Bonjour ,

 

voilà j'ai installé phbb forum quelque soit la version 2 ou 3 lors de l'in stallation quand j'entre mon adresse email monadresse@mondomaine

il ne l'accèpte pas il m'affiche une érreure du genre adresse email invalide dans la version 2 quand je laisse le champ vide il continue le plus normalement l'instalation mais sur la version 3 il n' accèpte que l'adresse email du genre monadresse@hotmail.com et il continue l'installation une fois l'installation terminée dans les deux version quand un nouveau membre veux s'enregistré il affiche quelque soit son adresse email l'érreure adresse email invalide il n'accèpte aucune aucune adresse email .je ne comprend pas pk ça ne fonctionne pas sachant que j'ai installé phbb forum en local avec easyphp

et j'ai testé la fonction mail avec un fichier php teste-mail.php et ça fonctionne très bien et je reçois l'email de teste dans ma boite alors j'arrive pas a comprendre pourquoi ça plante sur l'étape d'inscription aucune personne n' à pue s'enregistré dans mon forum est ce qu'il ya des modification a faire sur les fichier php de phbb et quels sont les fichiers concernés par cette étape d'inscription comment je peux réglé ce problème est ce qu'il ya une personne qui a rencontré ce genre de problème .

 

soyez nombreux SVP a me répondre j'en ai vraiment besoin ça fait un lap de temps que je me casse la tete a résoudre ce problème et rien a faire ça marche tjrs pas chez moi .

 

Merci.

Share this post


Link to post
Share on other sites

salam

Désolée ça n'a rien à voir avec le sujet mais je sais que tu jettera un coup d'oeil là dedans.

salima-annissa ecoutes moi "c moi :) j'espère que mon nom te dira qlq chose " j'ai essayé de te joindre à plusieurs reprises mais ça ne donne rien essayes de m'envoyer un MP car pour moi ça ne marche pas.En espérant bien sûr que t'es la personne à laquelle je crois

:)

Share this post


Link to post
Share on other sites

salut il faut dépassé les 50 message je crois

pour avoir accès a la MP

bonne chance salima anissa

Share this post


Link to post
Share on other sites

Il y a quelques mois j'avais installé chez moi c'était sans soucis, du moins à ce niveau là, je vais essayer de reinstaller plus tard et je vous dis quoi, sinon c'est la version Gold que vous avez installé ? en FR ?

Share this post


Link to post
Share on other sites

Merci pour vos réponses je ne parle pas des mp , j'ai installé la version gold fr oui c ça mais il refuse toute adresse email il m'affiche invalide adresse email lors de l'inscription ......

 

j'éspère que vous avez compris mon pb .

 

 

 

merci.

Share this post


Link to post
Share on other sites

comment vas tu meriem ?

moi je vais bien merci j'ai rencontré ta soeur a iben rouched elle a acouché ya des mois et je lui ai dit de te passé le bonjour ........

elle te resemble beaucoup au point ou j'avais crue que c'était toi..j'éspère qu'elle se porte bien elle avait l'aire trsè fatigué passe lui mon bonjour ..

alors ça va donnes de tes nouvelles , comment va ton fils ça va a ALger ça se passe bien ?

moi mon fils a grandi il commence a jeté quelque mots et dire blabla bla des phrases incompréhensible ....

 

enfin grosso modo ça roule ....

 

dans l'attente de te lire ...

 

portes toi bien j'attend de tes nouvelles tu ne te connectes plus sur msn messenger ????

ça marche pas les mp de mon coté aussi ......

bye .

Share this post


Link to post
Share on other sites
Bonjour ,

 

voilà j'ai installé phbb forum quelque soit la version 2 ou 3 lors de l'in stallation quand j'entre mon adresse email monadresse@mondomaine

il ne l'accèpte pas il m'affiche une érreure du genre adresse email invalide dans la version 2 quand je laisse le champ vide il continue le plus normalement l'instalation mais sur la version 3 il n' accèpte que l'adresse email du genre monadresse@hotmail.com et il continue l'installation une fois l'installation terminée dans les deux version quand un nouveau membre veux s'enregistré il affiche quelque soit son adresse email l'érreure adresse email invalide il n'accèpte aucune aucune adresse email .je ne comprend pas pk ça ne fonctionne pas sachant que j'ai installé phbb forum en local avec easyphp

et j'ai testé la fonction mail avec un fichier php teste-mail.php et ça fonctionne très bien et je reçois l'email de teste dans ma boite alors j'arrive pas a comprendre pourquoi ça plante sur l'étape d'inscription aucune personne n' à pue s'enregistré dans mon forum est ce qu'il ya des modification a faire sur les fichier php de phbb et quels sont les fichiers concernés par cette étape d'inscription comment je peux réglé ce problème est ce qu'il ya une personne qui a rencontré ce genre de problème .

 

soyez nombreux SVP a me répondre j'en ai vraiment besoin ça fait un lap de temps que je me casse la tete a résoudre ce problème et rien a faire ça marche tjrs pas chez moi .

 

Merci.

 

What is the email address? no sweat, I am not gonna use it for spamming, I am just trying to help. It might be that your email is not passing regular expression validation that phpbb is using.

Share this post


Link to post
Share on other sites

I think that all email adress are in expression like this : monnom@namedomain.some think's like com or fr or ....an other word ,so ...what'is the regular expression validation that phbb is using ?? if you know .it..??????.........

 

Iam waiting for your answer...................I want a lot of anwer please...................

 

thank's to answer me ..........

Share this post


Link to post
Share on other sites
I think that all email adress are in expression like this : monnom@namedomain.some think's like com or fr or ....an other word ,so ...what'is the regular expression validation that phbb is using ?? if you know .it..??????.........

 

Iam waiting for your answer...................I want a lot of anwer please...................

 

thank's to answer me ..........

 

I know that email are in somthing@something.somthing, not every email will pass validation.

 

regular express is : ^[a-z0-9&\'\.\-_\+]+@[a-z0-9\-]+\.([a-z0-9\-]+\.)*[a-z]+$

 

you can check your email against that regular expression online and see if it is validated.

 

Good luck.

Share this post


Link to post
Share on other sites

Bonjour tout le monde ,

 

personne n' à trouvé une solution pour mon problème ?

 

je cherche tjrs ....mais j'ai rien trouvé allez soyez sympa aidez moi un peu j'en ai vraiment besoin ...comment ça se fait que personne n'arrive à s'enregistré sur mon forum allez soyez cool cherchez avec moi ....

 

MERCI

Share this post


Link to post
Share on other sites

Bonjour tout le monde ,

 

voilà j'ai un nom de domaine qui contient un chiffre exemple mr3 c'est pour ça lors de l'enregistrement il me dit invalide mais avec un nom de domaine qui contient uniquement des lettres il valide l'enregistrement exemple salima@fas.mr3 ça c invalide mais salima@fas.mr est valide svp dites moi comment je modifis les fichiers php pour qu'il valide mon domaine qui contient un chiffre ou se trouve le controle de domaine est ce que je peux le changé ????

Finalement c'était là le pb ...

bon pour les personnes qui utilisent phbb forum version 3 FR et qui ont un problème lors de l'enregistrement genre invalide adresse email voilà la solution :

dans le paneau d'administration de phbb vous avez pramètres de sécurité tout en bas méttez NON ne pas vérifier l'email dans le registre MX .normalement ça marche très bien .

 

le seul pb en ce qui me concerne c'est que j'aimerais bien savoir comment rendre mon nom de domaine valide dans phbb sachant qu'il contient des chiffres ce qui le rend invalide et je ne peux pas le changer ...........

 

montrez moi svp comment supprimer le champ adresse email du formulaire d'enregistrement dans la version phbb 3 pas la version 2 parceque j'ai le scripte...

 

et merci.

merci .

Share this post


Link to post
Share on other sites

voilà quand j'ai consulté le journal des érreures ce que j'ai trouvé si quelcun a une idée comment je règle ce problème sachant que comme je voulais déjà dit il ne valide aucun enregistrement a cause du préfixe du nom de domaine meme lors de l'installation quand je lui donne une adresse email comme suit :

 

monnom@safi.pm5

 

voilà les érreures :

 

Erreur d’e-mail

» EMAIL/PHP/mail()

/forum/install/index.php

 

[phpBB Debug] PHP Notice: in file /includes/functions_messenger.php on line 410: mail() [function.mail]: SMTP server response: 554 Relay rejected for policy reasons.

 

 

 

Erreur d’e-mail

» EMAIL/PHP/mail()

/ucp.php

 

[phpBB Debug] PHP Notice: in file /includes/functions_messenger.php on line 410: mail() [function.mail]: SMTP server response: 554 Relay rejected for policy reasons.

 

 

merci.

Share this post


Link to post
Share on other sites

Salem,

 

just une question toute bete : d'ou tu sorts les mail du genre @aaa.mr3 !!????? t'es sure que ce type d'adresse existe ?? et pourquoi vouloir accepter à tout prix ces adresses bizard puisque les adresses "conventionnelles" sont validées !??

 

j'arrete la, ça fait trop de questions.:)

Share this post


Link to post
Share on other sites

écoutes dans une entreprise ou il ya un réseaux intranet on n'utilise pas des adresses comme hotmail yahoo il ya le nom de domaine crée par les administrateurs du réseau je veux dire propre a ce réseau alors je ne peux pas le changé tout le problème c'est qu'il contient des chiffres c'est pour ça l'adresse email n'ai pas validée j'éspère que vous avez compris mon pb .

 

qu'est ce que je doit changé dans les fichiers php de phbb pour qu'il me valide mes adresse email lors des enregistrements et meme lors de la première installation quand je fournis mon adresse email .

 

voir les érreures du journal en haut....

Share this post


Link to post
Share on other sites

[phpBB Debug] PHP Notice: in file /includes/functions_messenger.php on line 410: mail() [function.mail]: SMTP server response: 554 Relay rejected for policy reasons.

 

je ne connais rien à PHBB FORUM mais c'est le server smtp qui n'a pas validé le format du mail donc à mon avis rien n'a faire, on peut pas forcer une @ non valide.:( c'est comme si on voulait faire croire à un facteur qu'un micro-ondes est une enveloppe et qu'on essaie de le convaincre de la poster, y'en a qui nacceptent(DHL,FEDEX) et d'autres pas(POSTE ALGERIE).....désolé pour l'exemple mais j'ai pas trop d'imagination en ce moment.

Share this post


Link to post
Share on other sites

Désolé d'insister avec mes questions toutes betes mais c'est just pour voir plus clair :

c'est hébérgé ou exactement ? y'a bien un serveur smtp pour acheminer les mail à destination ! non ?

Share this post


Link to post
Share on other sites

Salem,

 

voir la configuration smtp du serveur, si tu donne plus de details la dessu y'aura surement des membre qui pouront t'aider.

 

@+

Share this post


Link to post
Share on other sites
Bonjour tout le monde ,

 

voilà j'ai un nom de domaine qui contient un chiffre exemple mr3 c'est pour ça lors de l'enregistrement il me dit invalide mais avec un nom de domaine qui contient uniquement des lettres il valide l'enregistrement exemple salima@fas.mr3 ça c invalide mais salima@fas.mr est valide svp dites moi comment je modifis les fichiers php pour qu'il valide mon domaine qui contient un chiffre ou se trouve le controle de domaine est ce que je peux le changé ????

Finalement c'était là le pb ...

bon pour les personnes qui utilisent phbb forum version 3 FR et qui ont un problème lors de l'enregistrement genre invalide adresse email voilà la solution :

dans le paneau d'administration de phbb vous avez pramètres de sécurité tout en bas méttez NON ne pas vérifier l'email dans le registre MX .normalement ça marche très bien .

 

le seul pb en ce qui me concerne c'est que j'aimerais bien savoir comment rendre mon nom de domaine valide dans phbb sachant qu'il contient des chiffres ce qui le rend invalide et je ne peux pas le changer ...........

 

montrez moi svp comment supprimer le champ adresse email du formulaire d'enregistrement dans la version phbb 3 pas la version 2 parceque j'ai le scripte...

 

et merci.

merci .

 

Glad you came to the conclusion that the email is not being validated because of the address itself that's why I asked about it.

 

Find the file where the regular expression is, and modify it.

 

PHPBB express: ^[a-z0-9&\'\.\-_\+]+@[a-z0-9\-]+\.([a-z0-9\-]+\.)*[a-z]+$

Modify it to

^[a-z0-9&\'\.\-_\+]+@[a-z0-9\-]+\.([a-z0-9\-]+\.)*[a-z0-9]+$

 

It will work.

Share this post


Link to post
Share on other sites

the file is \includes\functions.php, open it and go to the function "get_preg_expression($mode)"

 

change this portion

case 'email':

return '(?:[a-z0-9\'\.\-_\+\|]|&)+@[a-z0-9\-]+\.(?:[a-z0-9\-]+\.)*[a-z]+';

break;

 

With

case 'email':

return '(?:[a-z0-9\'\.\-_\+\|]|&)+@[a-z0-9\-]+\.(?:[a-z0-9\-]+\.)*[a-z0-9]+';

break;

 

and you're good to go.

Share this post


Link to post
Share on other sites

Bonjour tout le monde ,

merci à tous de m'avoir répondu , merci a mouradski pour ses éfforts c'est très gentille..............

 

DARKVAder thank you thank you thank you thank you thank you .............................................................................merci beaucoup beaucoup ça a marché très bien je ne sais pas comment terremercié je t'envois une tartelette , une petite boisson merci alik bezzzzzzzzzzzaaaaaaaaafffffffffffffffffffffffff tu m'as aidé a réglé un grand pb wallah c très très gentille ..................................................

 

I am very hapyyyyyyyyyyyyyyyyyyy!!!!!!!!!!!!!!!!!!!!!!!

 

thank's thank's and thank's ................

 

je vais posté mes autres pbs les jours qui suit je vois qu'il ya des gens vraiment fort dans ce forum ça m'encourage a avancé chjouiya

 

a vrais dire je nage dans les pbs informatique andy bezzafffffffff

 

wallah merci bcp

Share this post


Link to post
Share on other sites
Bonjour tout le monde ,

merci à tous de m'avoir répondu , merci a mouradski pour ses éfforts c'est très gentille..............

 

DARKVAder thank you thank you thank you thank you thank you .............................................................................merci beaucoup beaucoup ça a marché très bien je ne sais pas comment terremercié je t'envois une tartelette , une petite boisson merci alik bezzzzzzzzzzzaaaaaaaaafffffffffffffffffffffffff tu m'as aidé a réglé un grand pb wallah c très très gentille ..................................................

 

I am very hapyyyyyyyyyyyyyyyyyyy!!!!!!!!!!!!!!!!!!!!!!!

 

thank's thank's and thank's ................

 

je vais posté mes autres pbs les jours qui suit je vois qu'il ya des gens vraiment fort dans ce forum ça m'encourage a avancé chjouiya

 

a vrais dire je nage dans les pbs informatique andy bezzafffffffff

 

wallah merci bcp

 

you are welcome, I am glad you fixed it. As for the tart and drink I don't think they would survive the trip to USA, but thanks anyway.

Share this post


Link to post
Share on other sites

Bonjour tout le monde ,

 

j'ai un autre petit pb sur phbb mon forum voilà pour mon site web j'ai crée un logo en animation flash logo.swf je veux remplacé mon logo de phbb site_logo.gif par le mien malheuresement en faisant ça dans le paneau administration dans pack image j'ai mis mon logo dans imageset du répertoire prosilver mais il ne me donne dans la liste déroulante que les .gif pas de sxf comment je fais quelcun a une idée et merci.

 

2 ème pb:

 

les smeyle quand j'insère un smeylé dans un méssage privé je ne vois pas une image mais une ligne de caractères avez vous une idée c'est du a quoi ?

 

l'avatar aussi malgrès que j'ai activé la galerie mais je ne vois pas l'avatar quand je l'insère .............

 

merci

Share this post


Link to post
Share on other sites
Bonjour tout le monde ,

 

j'ai un autre petit pb sur phbb mon forum voilà pour mon site web j'ai crée un logo en animation flash logo.swf je veux remplacé mon logo de phbb site_logo.gif par le mien malheuresement en faisant ça dans le paneau administration dans pack image j'ai mis mon logo dans imageset du répertoire prosilver mais il ne me donne dans la liste déroulante que les .gif pas de sxf comment je fais quelcun a une idée et merci.

 

2 ème pb:

 

les smeyle quand j'insère un smeylé dans un méssage privé je ne vois pas une image mais une ligne de caractères avez vous une idée c'est du a quoi ?

 

l'avatar aussi malgrès que j'ai activé la galerie mais je ne vois pas l'avatar quand je l'insère .............

 

merci

 

 

I might be able to help you with the first request if you know how to write some HTML code.

 

Let me know.

 

Thanks

Share this post


Link to post
Share on other sites

bonsoir ,

 

oui DARKvader je métrise très bien html ;php je viens de terminer mon site web en flash et php , i know ths two language and javascript anny problem

tnahk you

Share this post


Link to post
Share on other sites
bonsoir ,

 

oui DARKvader je métrise très bien html ;php je viens de terminer mon site web en flash et php , i know ths two language and javascript anny problem

tnahk you

 

Alright,

 

open \styles\prosilver\template\overall_header.html and look for this code here

{SITE_LOGO_IMG}

 

remove the whole line and replace it with your own HTML that embeds flash file like






 

make sure the path to swf file is relative to phpBB root directory like

src="www.domain.com/somefilename.swf", not to template file. Also you might want to remove "" before and "" after that code.

 

Good Luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Posts

    • si t'a de temps en temps l'impression que ta connection est parfaite c'est parceque  tu joues sur  un serveur tres proche geographiquement de l'algerie, c'est soit l'espagne, le sud de la france ou l'italie personellement sur mw2019, des que je tombe sur un serveur allemand /anglais  c'est la cata, le top pour moi c'est l'italie en ce que concerne la fibre, c'est un  passage obligé pour les gamers, mais je me fait pas trop d'illusions, y'a pleins de streamers qui ont du lag avec connection 100% fibre et un ping monstrueux (20-25ms)
    • Bonsoir. J'ai entendu dire que les immigrés Doivent changer obligatoirement leurs devis à la douane.sinon ils seront saisie Qui peut confirmer ?
    • @mahdidu10 j'ai un PING entre 50 - 95 j'ai l'ADSL en GDMT ping 50 - 55 en ADSL 2+ PING entre 75 et 95 mais la connexion sur les Jeux en Ligne chez moi et comme bogué j'ai un Retard et un LAG ANORMALE dont j'ignore la cause ( Peut être le BUFFER BLOAT, La Surcharge du réseau AT la ou j'habite ou un système de filtration internet d'AT...) des fois mais Très tres rarement la connexion dans les Jeux Online devient Parfaite ( 1 ou 2 jours par 6 mois) je sais pas pourquoi, peut être le moment ou ils désactivent  leur système de filtration de internet ? ou ca correspond au moments ou ils testent le câble Orval ce qui améliore la connexion ?  tout ca cest la grande question de ma vie, c pour ça que je veux savoir si une connexion Fibre améliore le Gameplay Online !
    • Ça ne va pas seulement baisser à cause de la fermeture des frontières, chose qui était connu, sauf pour certains qui ont suivi des rumeurs de réouverture. Mais ça va baisser à cause de ça : https://www.tsa-algerie.com/algerie-la-fin-de-la-convertibilite-commerciale-du-dinar/  
    • Ça ne va pas seulement baisser à cause de la fermeture des frontières, chose qui était connu, sauf pour certains qui ont suivi des rumeurs de réouverture. Mais ça va baisser à cause de ça : https://www.tsa-algerie.com/algerie-la-fin-de-la-convertibilite-commerciale-du-dinar/
×
×
  • Create New...