Jump to content

Recommended Posts

Salam,

Aujourd'hui j'ai décidé de faire un grand pas en installant archlinux, seulement voilà en essayant de faire une mise à jour j'ai eu plein de messages d'erreurs, c'est alors que j'ai essayé de faire un ping : ping: unknown host

 

J'ai essayé de faire la commmande pppoeconf dont j'ai l'habitutde sur debian/ubuntu mais ça marche pas (je crois que cet utilitaire n'est pas présent) :(

 

J'ai une connexion fawri avec le modeme ethernet HUAWAEI MT880.

 

Alors je viens ici vous demmander si des archlinuxiens (Havoc je crois ?!) passent par ici de bien vouloire m'aider, merci :)

 

Cordialement.

Edited by Tuxargon
Link to post
Share on other sites

Salut, pour configurer une connexion Fawri sous Archlinux il faut pas taper :

 

pppd file /etc/pppoe.conf

 

Il suffit alors de créer ton fichier pppoe.conf selon ce modèle :

Il doit y avoir une entrée correspondante avec le mot de passe dans /etc/ppp/pap-secrets et/ou dans /etc/ppp/chap-secrets.

user "nom_utilisateur"

# Chargement du plugin PPPoE
plugin rp-pppoe.so

# Interface Ethernet à laquelle le modem est raccordé
nas0

# Suppose que le FAI attribuera une adresse IP dynamiquement.
noipdefault

# Tenter de récupérer les adresses de DNS chez le FAI
usepeerdns

# Utiliser cette connexion comme route par défaut
defaultroute

# Forcer pppd à "renuméroter" en cas de déconnexion
persist

# Ne pas demander une authentification distante
noauth

 

Le paquet pppoeconf n'existe pas sous Archlinux, n'oublie pas d'installer le paquet br2684ctl et de suivre les mêmes étapes que sous Debian.

Edited by Slown
Link to post
Share on other sites

Salam et merci pour cette réponse rapide :)

 

pppd file /etc/pppoe.conf me renvoit ceci :

Plugin rp-pppoe.so loaded.

RP-PPPoE plugin version compiled  against pppd 2.4.4

 

br2684ctl start me renvoit ceci :

Bridgin ATM on PPPoE [FAIL]

 

Dans les logs je vois cette ligne qui me parrait un peu bizzard :

Timeout waiting for PADO packets

 

En résumer, ça marche pas :(

 

Quelqu'un a une autre idée ?

 

PS : Je précise que j'ai du ethernet ;)

Link to post
Share on other sites
Guest HAVOC

L'interface nas0 ce n'est pas quand le modem est relié en USB uniquement ? Je pense que si il est relié en ethernet l'interface doit être eth0 ou un truc du genre.

 

Ca te donne quoi un ifconfig ? (il t'affiche quoi comme interfaces en tout)

 

Sinon tu peux essayé de modifier le fichier et y mettre eth0 à la place de nas0

 

Sinon je te propose en attendant (histoire d'installer le reste de la distrib) de configurer ton modem en routeur comme ça tu n'as qu'à lancé le dhcpd eth0 et voilààà.

 

Sinon, tu as téléchargé quoi comme image d'Archlinux et tu as selectionné quels paquetages lors de l'installation ?

Edited by HAVOC
Link to post
Share on other sites

Salam,

 

Les testes que j'ai fait c'était avec eth0 pas nas0 :)

 

J'ai installé archlinux ne version core et j'ai installé tous les pauqets du groupes main et main-devils.

 

Voici ce que ifconfig me renvois :

eth0      Link encap:Ethernet  HWaddr 00:22:68:35:F7:FD  
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:3 errors:0 dropped:0 overruns:0 frame:0
         TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000 
         RX bytes:180 (180.0 b)  TX bytes:2736 (2.6 Kb)
         Interrupt:252 Base address:0xe000 

lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0 
         RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

 

Sinon en fait comment pour le mode routeur ?

Link to post
Share on other sites
Guest HAVOC
Salam,

 

Les testes que j'ai fait c'était avec eth0 pas nas0 :)

 

J'ai installé archlinux ne version core et j'ai installé tous les pauqets du groupes main et main-devils.

 

Très bien, tu as suivi la bonne démarche. Tu aurais pu ne pas installer certains paquets comme ceux pour les cartes wifi si tu n'en as pas mais ce n'est pas bien méchant, il vaut mieux plus que moins dans ce cas de figure.

 

 

comment pour le mode routeur ?

 

Bon... là tu auras besoin dans un premier temps de démarrer ton PC sous Windows ou sous une autre version de Linux qui soit fonctionnelle. Tu configures ta carte réseau sur une IP fixe : 192.168.1.2 et masque reseau 255.255.255.0

 

Voilà, maintenant dans ton firefox (ou IE) tu entres l'adresse : 192.168.1.1 ce qui va ouvrir le panel d'administration de ton modem-routeur, là tu dois entrer en login : admin et en password : admin

 

En suite là, tu regardes dans BASIC, je ne sais plus si c'est dans ADSL MON ou WAN en tout cas tu trouveras où mettre tes identifiants de connexion... penses à activer le DHCP.

 

Une fois ton modem bien configuré, tu sauvegardes la configuration et tu redémarre le modem, il va se connecter tout seul comme un grand.

 

Sous archlinux tu n'auras qu'à taper dhcpd eth0 (ou tu passes par l'assistant d'installation) pour recevoir une adresse IP et être connecté.

 

Voilà... maintenant tu peux installer xorg et l'environnement de ton choix...

Link to post
Share on other sites
Guest HAVOC
Le modem SmartAX MT880 utilise l'Ethernet over PPP, je ne pense pas qu'une simple configuration d'adresses va régler le problème.

 

Il a un mode routeur ce modem non ?

Link to post
Share on other sites
Très bien, tu as suivi la bonne démarche. Tu aurais pu ne pas installer certains paquets comme ceux pour les cartes wifi si tu n'en as pas mais ce n'est pas bien méchant, il vaut mieux plus que moins dans ce cas de figure.

 

 

 

 

Bon... là tu auras besoin dans un premier temps de démarrer ton PC sous Windows ou sous une autre version de Linux qui soit fonctionnelle. Tu configures ta carte réseau sur une IP fixe : 192.168.1.2 et masque reseau 255.255.255.0

 

Voilà, maintenant dans ton firefox (ou IE) tu entres l'adresse : 192.168.1.1 ce qui va ouvrir le panel d'administration de ton modem-routeur, là tu dois entrer en login : admin et en password : admin

 

En suite là, tu regardes dans BASIC, je ne sais plus si c'est dans ADSL MON ou WAN en tout cas tu trouveras où mettre tes identifiants de connexion... penses à activer le DHCP.

 

Une fois ton modem bien configuré, tu sauvegardes la configuration et tu redémarre le modem, il va se connecter tout seul comme un grand.

 

Sous archlinux tu n'auras qu'à taper dhcpd eth0 (ou tu passes par l'assistant d'installation) pour recevoir une adresse IP et être connecté.

 

Voilà... maintenant tu peux installer xorg et l'environnement de ton choix...

 

A ce que je vois tu n'a pas de systéme graphique, si tu as links ( le navigateur en mode console ) tu peux configurer ton modem en routeur comme l'a expliqué HAVOC sans passer par un autre systéme (win ou autre nix).

Voila j'espére que ca pourra t'aider ;)

#links 192.168.1.1

Link to post
Share on other sites
Guest
This topic is now closed to further replies.


  • Posts

    • salut mon Dlink est bien placé , en hauteur, force de signal extra mais à certains moment j'ai le wifi qui décroche tout seul depuis mon iphone malgré une force de signal trés bonne, je perds la connection et l'icone wifi disparait !! des réglages particuliers à faire sur mon nouveau Dlink 124 ? j'ai utilisé le logiciel inSSIDer mais j'ai pas compris grand chose à part qu'il fallait mettre le canal 11  sur mon Dlink c'est réglé channel number sur auto et current channel 1 autres réglages channel width est sur 20/40 Mhz le logiciel me conseil de mettre sur 40 seulement des suggestions ? 
    • C'est très claqué sur MyDzStore quand même, https://mydzstore.com/ mais bon, c'est à l'image du pays  
    • salut 80cm suffit pour astra. et  nilesat au nord de l'Algerie mais ca dépend aussi de la qualité de la tête LNB . Tu comprendras tout sur cette page        
    • j'ai activé l'adsl mercredi samedi 16:55 raccordé. je viens de remarqué le message et les appelle en absence d'AT
    • merci pour la réponse...mais c'est pas ce que je demandais... 80cm suffit pour astra...ou eutelsat ou nilesat oui.... MAIS moi je veux savoir si une LNB monobloc-icone (c'est pas la meme chose qu'une tete simple a 4 sortie) captera sur une parabole de 80.... helas tu n'as pas fais de tests...et la plupart des vendeurs ne savent pas...
×
×
  • Create New...